Resolved
We have resolved the incident and improved some of our infra to lower the risk of it happening again with those conditions.
Monitoring
Our metrics are back to normal, we are still implementing more safeguards in the meantime while we keep monitoring
Identified
we have identified the issue and are working on resolving it asap
Investigating
We are investigating why our job processing are being much slower than usual