Resolved
Our infrastructure has been in a normal state for the past 90min, we'll keep a eye on it but for now we consider that incident resolved.
Identified
We had a temporary huge spike in usage, we are working on a fix to ensure such spikes are absorbed more easily.
Investigating
We are noticing an increase in our response times and are currently investigating that issue.